Data missing from Sharethrough for Publishers
Incident Report for Sharethrough
Resolved
This incident has been resolved.
Posted May 16, 2018 - 13:09 PDT
Investigating
We have received notification of data missing from Sharethrough for Publishers. We are currently investigating this issue and will have an update shortly. Thank you for your patience.
Posted May 16, 2018 - 03:25 PDT