Sharethrough Reporting Delays
Incident Report for Sharethrough
Resolved
This incident has been resolved. Reporting for 1/5 through 1/6 is now available in the Sharethrough platform.
Posted Jan 07, 2019 - 12:52 PST
Investigating
Sharethrough is experiencing an issue with delayed reporting for 1/5 through 1/6 in the Sharethrough platform. We are currently working on this and will send updates periodically. We apologize for the inconvenience.
Posted Jan 07, 2019 - 07:26 PST