Data Processing Delay
Incident Report for Sharethrough
Resolved
A fix has been implemented and data processing and reporting systems are back online. Data should be populated in the platform soon if it is not already. We are monitoring the results of the fix but everything should be resolved.
Posted Jan 21, 2020 - 16:35 PST
Identified
There has been a delay in our internal data processing and our reporting systems are missing data for yesterday. We apologize for the inconvenience and hope to get this issue resolved shortly.
Posted Jan 21, 2020 - 09:40 PST
This incident affected: Sharethrough Native Exchange (STX).