STX unable to serve Ads
Incident Report for Sharethrough
Resolved
This incident has been resolved.
Posted Dec 09, 2018 - 11:05 PST
Update
The service has recovered and we are monitoring
Posted Dec 09, 2018 - 08:40 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2018 - 08:40 PST
Investigating
We are currently investigating the issue
Posted Dec 09, 2018 - 08:29 PST
This incident affected: Sharethrough Native Exchange (STX).