STX outage
Incident Report for Sharethrough
Resolved
This incident has been resolved.
Posted Sep 25, 2019 - 10:30 PDT
Update
We are continuing to investigate this issue.
Posted Sep 25, 2019 - 10:00 PDT
Investigating
From 11:00 to 11:30 AM pacific time
Posted Sep 25, 2019 - 10:00 PDT
This incident affected: Sharethrough Native Exchange (STX).