Sharethrough Reporting Experiencing Delays
Incident Report for Sharethrough
Resolved
This incident has been resolved. Reporting is now up-to-date in SFP.
Posted Jun 14, 2018 - 13:41 PDT
Identified
The issue has been identified and a fix is being implemented. Confirming that delivery has not been affected.
Posted Jun 14, 2018 - 04:45 PDT
Investigating
We are currently investigating this issue.

Thank you for your patience.
Posted Jun 14, 2018 - 04:19 PDT
This incident affected: Sharethrough Native Exchange (STX).