Inaccurate data in platform reporting 01/23/2018.
Incident Report for Sharethrough
Resolved
This issue has been resolved. If you suspect you are seeing this issue please email: support@sharethrough.com. Thank you for your patience.
Posted Jan 25, 2018 - 09:41 PST
Identified
We have identified an issue causing inaccurate data in our platforms for January 23, 2018. We apologize for this inconvenience and are working on this at the moment. We will send update with progress on the fix. Thank you.
Posted Jan 24, 2018 - 10:02 PST