Known issue with DBM/Bidswitch.
Incident Report for Sharethrough
Resolved
This incident has been resolved.
Posted Apr 04, 2018 - 09:32 PDT
Identified
There is a known issue with DBM/Bidswitch. If you have noticed scaling issues with DBM campaigns, here is a summary of the likely cause:

Beginning on 2/22, DBM campaigns saw sharp decreases in spend. Many campaigns were unable to scale or deliver at all. DBM told us that they're still bidding with these campaigns.

We believe that the issue is with BidSwitch not sending through the bids with deals and the team is working with BSW to investigate and provide a solution.

We made the recommendation that clients adjust campaigns by removing Deal IDs and move to sitelist targeting instead. These campaigns saw increases in spend and scaling.
Posted Mar 08, 2018 - 08:07 PST